=^.^=

Portage Errors: app-admin/logrotate is blocking sys-apps/portage

If you haven't kept your system up to date you may run into the following when attempting to update portage:

[ebuild     U ] sys-libs/libsepol-2.1.0 [2.0.32]
[ebuild     U ] sys-libs/libselinux-2.1.0 [2.0.71] USE="(python%*)"
[ebuild     U ] sys-apps/portage-2.1.10.11 [2.1.7.16] USE="(ipc%*) less%* (python2%*)"
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <app-admin/logrotate-3.8.0 ("<app-admin/logrotate-3.8.0" is blocking sys-apps/portage-2.1.10.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'sys-apps/portage-2.1.10.11', 'merge') pulled in by
    portage

  ('installed', '/', 'app-admin/logrotate-3.7.8', 'nomerge') pulled in by
    app-admin/logrotate required by world

Simply update logrotate before proceeding:

# emerge --update logrotate; emerge --update portage

Comments

There are no comments for this item.