=^.^=

Portage Errors: app-admin/php-toolkit is blocking app-admin/eselect-php

Gentoo has started using a meta-package to manage PHP. If you are upgrading an old system you may encounter this error:

[blocks B      ] app-admin/php-toolkit ("app-admin/php-toolkit" is blocking app-admin/eselect-php-0.6.2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-admin/php-toolkit-1.0.1::gentoo, installed) pulled in by
    app-admin/php-toolkit required by (dev-lang/php-5.2.12::gentoo, installed)

Open /var/lib/portage/world and delete the line for dev-lang/php. Now emerge virtual/httpd-php:

# emerge virtual/httpd-php

Comments

There are no comments for this item.