=^.^=

Portage Errors: sys-devel/patch is blocking sys-libs/glibc

If you run into this error while updating glibc:

# emerge --update gcc glibc

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies -[[email protected] ~]# xm console dns2
... done!
[ebuild     U ] dev-libs/mpfr-3.0.1_p4 [2.4.1_p5]
[ebuild     U ] sys-devel/gcc-config-1.5-r2 [1.4.1]
[ebuild  N    ] virtual/os-headers-0 
[ebuild  N    ] dev-libs/mpc-0.8.2 
[ebuild  NS   ] sys-devel/gcc-4.5.3-r2 [4.3.4] USE="cxx hardened mudflap nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -fortran -gcj -graphite -gtk (-libssp) -lto (-multilib) -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla" 
[ebuild     U ] sys-libs/glibc-2.13-r4 [2.10.1-r1] USE="hardened*" 
[ebuild     U ] sys-devel/gcc-4.3.6-r1 [4.3.4] USE="cxx%* hardened* nptl* -fortran* (-libssp) -nossp%" 
[blocks B     ] <sys-devel/patch-2.6 ("<sys-devel/patch-2.6" is blocking sys-libs/glibc-2.13-r4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'sys-libs/glibc-2.13-r4', 'merge') pulled in by
    >=sys-libs/glibc-2.8 required by ('ebuild', '/', 'sys-devel/gcc-4.5.3-r2', 'merge')
    >=sys-libs/glibc-2.8 required by ('ebuild', '/', 'sys-devel/gcc-4.3.6-r1', 'merge')
    glibc


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Update patch first and carry on:

# emerge --update patch
# emerge --update glibc gcc

Comments

• Denis

Thank you for posting this! I was just updating my Gentoo Linux install and ran into this problem. All the best to you!