=^.^=

Non-Superuser Write to VFAT

FAT32 (vfat) does not recognise conventional linux permissions; granting the ability to write must be done at the time of mounting. Generally the appropriate permissions are applied when mounting a vfat volume through an autoconfiguring GUI utility (i.e file manager) but if you are quickly trying to copy files to or from an sd card, memory stick, etc. from the command line you have two options aside from doing everything as root (and reloading your X file manager as such, for example): create a (semi-)permanent entry in /etc/fstab with the user or users option (see the fstab man page for more information) and use the mount command as that user or mount the volume assigning ownership with mount options on the CLI:
mount /dev/vfat_partition_node /mnt/mountpoint -o uid=1000[,gid=1000]

Replace 1000 with the UID of the user you wish to give full ownership of the filesystem contents to and, optionally, the GID of the group you would like to assign ownership to. Other options like umask can modify permissions globally at mount, check the man page for more details.

Comments

There are no comments for this item.